Microsoft has moved away from IE and released Edge in 2015, their new browser.
IE was lagging far behind other browsers such as Chrome and Firefox in terms of technology and compatibility.

We have therefore stopped supporting IE so we can deliver a better experience in Aula. When we spend extra time supporting IE, we take time away from working on the features that make Aula better. Weโ€™re very sorry about the hassle. ๐Ÿ˜žย 

Alternatively, on Windows, you can simply download and use Chrome, Edge, Firefox, or Opera.

Why block IE instead of just making it clear that it is not supported?

We aim to help you experience Aula in the best possible way. If we arenโ€™t actively fixing issues or bugs related to IE, your experience will suffer and we want to avoid that completely.

Did this answer your question?